You are not logged in.

  • Login

Dear visitor, welcome to Nordlandtrilogie HD - Offizielles Forum. This is the old forum of the Realms of Arkania Remakes. You can find the new Forum at forum.schicksalsklinge.com. This forum is just for reference, posts and registration are deactivated.

Vaerin

Unregistered

1

Sunday, August 4th 2013, 4:15am

Bug compilation

A few things I've found. Trying to be as detailed as I can. If there's any questions, I'll be happy to clarify or make it as easy to diagnose as I can. I must say this game is shaping up quite a bit. Looks amazing and the weather was a nice surprise.

Main storyline related
- Very difficult to talk to the hetman. I had to face a certain direction just to get the tooltip to show up, and after multiple clicks it finally worked. Couldn't get it to work facing the camp directly.





- Talking to Isleif Olgardsson in Stonrock/Felsteyn gives numbers instead of peoples' names when you ask about them.





MIsc Errors
- During camp, time passes VERY fast, even if you idle for just a bit. Days can pass in a matter of seconds if you're not careful.
- Spells : Fulminictus Thunder Shim? Maybe thunderbolt? And is Penetrizzel supposed to be Penetrating?
- Steppe dogs and stag beetles showing up as skeletons.

- The entrance to the Old Bailey in Thorwal seems to be broken. No "I demand to see Master Dramosch!" option, but maybe I needed to go to a different house or something.
- No combat sounds at all, except for the spell chants.
- Crashes somewhat often after loading a savegame. Just hangs for a while without doing anything. FIrst load is okay, second always crashes.


A few screenshots -



Also, the message when someone has found food is a placeholder as well.



A lot of houses in Thorwal and Stonrock/Felsteyn showing up as this





But Cath is a woman :(





This post has been edited 5 times, last edit by "Vaerin" (Aug 4th 2013, 8:04am)


2

Sunday, August 4th 2013, 9:16am

Thanks for your detailed bug reports (I really love them - its easy to work with them!). I have sent them to the devs so they can fix them.

3

Sunday, August 4th 2013, 2:49pm

Hello Vaerin, thank you very much for your detailed Bug reports! I was already able to fix most of the text bugs, although the tavern is a quite complicated ... well, lets call it "mess", where wrong branches may still hide. Anyways, regarding the Savegame crashes: Would you mind doing the following:
- Reproduce the Savegame Hang
- End the game (e.g. by pressing the close button)
- attach the output_log.txt File located in <install directory>/schick_data/

This would be *very* helpful to fix the problem, because currently I wasn't really able to find a reason for such a strange behaviour. Thank you very much for your Help, it is greatly appreciated!

Edit: And regarding Master Dramosch, you first need a hint (meaning a trigger to start the quest at all) in order to get this option. You can get this hint in any tavern or talking nicely to any trader or innkeeper. But something is still wrong there, because the whole explanation part is missing right now, I'll look into that as well.
Firefox ist immer schuld :)

Vaerin

Unregistered

4

Monday, August 5th 2013, 8:56am

Thanks guys! I will remember to do that in the future. I tried recreating the savegame loading bug, but everything worked just fine so it looks like you have already fixed it! :) And the Bailey works just fine as well.

My female characters are still referred to as "It" when they have insufficient spell points to cast a spell, however :/

I appreciate the response and I'm happy to be of help to you. You are doing an amazing job getting this game working well.

5

Monday, August 5th 2013, 9:05am

We are doing, whats possible (and sometimes a bit more) ;) . I will have a look at Cath again, perhaps its just a problem of a wrong pronoun placeholder.

Vaerin

Unregistered

6

Tuesday, August 6th 2013, 4:44pm

It's appreciated. Thanks! :)

Similar threads